[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Edits to Emacs packaging guidelines page



On Wed, Jan 21, 2009 at 11:07 AM, Jonathan Underwood
<jonathan underwood gmail com> wrote:
> Well, actually, the version number is really an indication of the
> lowest version that is compatible with the elisp that you're about to
> generate - nothing changed in this regard between 22.1 and 22.2 (or
> 22.3).
>
> Within the buildsystem, the hardcoded versions here are never used, as
> the true version is found at package build time. However, those stupid
> hardcoded versions are there to stop the building of SRPMs breaking
> prior to package building - BuildRequires aren't satisfied when the
> SRPM is built, so pkg-config isn't present.
>
> So, yeah, no harm in those updates, but not a big deal.
>
> [Aside: I am in the process of adding RPM macros to simplify this
> rather messy pkg-config use, once that is in place I'll propose
> changes to the guidelines.]
>
> J.

Okay.  However, the XEmacs paths are still wrong.  Can those be fixed
in the meantime?  Thanks,
-- 
Jerry James
http://loganjerry.googlepages.com/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]