[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: readline update?



Miroslav Lichvar (mlichvar redhat com) said: 
> I'd like to update readline to the latest version 6.0. The problem is
> that the license was changed to GPLv3+ and we have some GPLv2 packages
> using readline.
> 
> A possible replacement is the editline library which provides a
> compatible interface and is licensed under BSD, unfortunately it
> doesn't handle UTF-8.
> 
> Are we stuck with readline 5.2? Suggestions?

I suppose the first question is whether or not 5.2 and 6.0 are
ABI-compatible; if they're not, a parallel intsall would be simplest.

Bill


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]