[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: an update to automake-1.11?



On Sunday 05 July 2009 07:45:46 am Sam Varshavchik wrote:
> *snip*
>
> With a subsequent release, you'll still
> have to rebase your existing patch, if the new release did not fix the
> original bug. As I understand, rpm's default settings now reject fuzz in
> patch files, so you'll just have to do it, now. And since the likelyhood of
> configure changing in a new release is no different than any other source
> file getting changed, on average, believing that some work can be saved
> just by choosing to patch a different file, then the one that really needs
> to be patched, is somewhat naive.

The problem is that configure scripts are not written by a human, but 
generated by autoconf. It is easy to make small changes to configure.ac and 
generate large changes in configure. This makes it easier to rebase patches 
against configure.ac.

Regards,
-- 
Conrad Meyer <cemeyer u washington edu>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]