[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: readline update?



On Fri, Jul 03, 2009 at 05:55:21PM -0400, Bill Nottingham wrote:
> Miroslav Lichvar (mlichvar redhat com) said: 
> > I'd like to update readline to the latest version 6.0. The problem is
> > that the license was changed to GPLv3+ and we have some GPLv2 packages
> > using readline.
> > 
> > A possible replacement is the editline library which provides a
> > compatible interface and is licensed under BSD, unfortunately it
> > doesn't handle UTF-8.
> > 
> > Are we stuck with readline 5.2? Suggestions?
> 
> I suppose the first question is whether or not 5.2 and 6.0 are
> ABI-compatible; if they're not, a parallel intsall would be simplest.

They use different sonames, so parallel install will be probably the
least painful way.

Review requst for compat-readline5:
https://bugzilla.redhat.com/show_bug.cgi?id=510022

After the package is accepted, I'll start patching the packages
(except gnu-smalltalk and kdeedu) to build correctly with the compat
package. Let me know if you don't want me to touch your package or
want to use editline instead.

Thanks,

-- 
Miroslav Lichvar


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]