[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 3Dsee.net java applet crashes firefox



On Thu, Jul 9, 2009 at 11:29 PM, Mat Booth<fedora matbooth co uk> wrote:
> On Thu, Jul 9, 2009 at 10:15 PM, Mat Booth<fedora matbooth co uk> wrote:
>> I get an intermittant segfault in Firefox [1] when viewing the items
>> in the gallery over at http://3dsee.net/Gallery (once even trashing
>> the display and locking the machine up solid).
>>
>> Should I report this against Firefox or Java?
>>
>> I have the following installed:
>>
>> java-1.5.0-gcj.x86_64                                     1.5.0.0-28.fc11
>> java-1.6.0-openjdk.x86_64                                 1:1.6.0.0-22.b16.fc11
>> java-1.6.0-openjdk-plugin.x86_64                          1:1.6.0.0-22.b16.fc11
>> firefox.x86_64                                            3.5-1.fc11
>>
>>
>> [1] Running firefox from the terminal produces:
>>
>> JNLPAppletLauncher: static initializer
>> os.name = linux
>> nativePrefix = lib  nativeSuffix = .so
>> tmpRootDir = /tmp/jnlp-applet/jln4687162377651411657
>> Applet.init
>> subapplet.classname = ACIDVisionViewer.ObjViewer
>> subapplet.displayname = ACID Vision Viewer
>> Applet.start
>> os.name = linux
>> os.arch = amd64
>> processNativeJar: using previously cached:
>> /home/mbooth/.jnlp-applet/cache/3dsee_net/7a0e806f70cba53e5de753282fb8bea46fe32ffa/lib_j3dcore-ogl_so.jar
>> validateCertificates:
>> VALIDATE: libj3dcore-ogl.so
>> extractNativeLibs:
>> EXTRACT: libj3dcore-ogl.so(j3dcore-ogl)
>> JNLPAppletLauncher.loadLibrary("j3dcore-ogl")
>>    loading: /tmp/jnlp-applet/jln4687162377651411657/jln7242786902609691381/libj3dcore-ogl.so
>> JNLPAppletLauncher: static initializer
>> os.name = linux
>> nativePrefix = lib  nativeSuffix = .so
>> tmpRootDir = /tmp/jnlp-applet/jln4687162377651411657
>> Applet.init
>> subapplet.classname = ACIDVisionViewer.ObjViewer
>> subapplet.displayname = ACID Vision Viewer
>> Applet.start
>> os.name = linux
>> os.arch = amd64
>> /usr/lib64/firefox-3.5/run-mozilla.sh: line 131:  3605 Segmentation
>> fault      "$prog" ${1+"$@"}
>>
>>
>
> This screenshot is quite good, not had a good crash like this in ages:
>
> http://mbooth.fedorapeople.org/3dsee.png
>
> Though after a little thought, it could be the proprietary nvidia
> driver I'm using. I'll hold off reporting a bug until I try it with a
> different driver.

Works fine here.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]