[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: x86_64 packages depends on i586.



2009/7/10 Tom "spot" Callaway <tcallawa redhat com>:
> On 07/10/2009 05:58 PM, Joshua C. wrote:
>> I made a custom x86_64 livecd (f11) and found that the following
>> x86_64 packages depend on i586 and i686. Is this an error when
>> compiling those packages or they do need the 32 bits?
>>
>>  mesa-libGL-devel.x86_64 needs
>>
>>  glibc.i686
>>  libdrm.i586
>>  libdrm-devel.i586
>>  nss-softokn-freebl.i586
>
>>  pulseaudio-module-x11.x86_64  needs
>>
>>  alsa-lib.i586
>>  dbus-libs.i586
>>  e2fsprogs-libs.i586
>>  flac.i586
>>  gdbm.i586
>>  glibc.i586
>>  libICE.i586
>>  libSM.i586
>>  libX11.i586
>>  libXau.i586
>>  libXext.i586
>>  libXtst.i586
>>  libasyncns.i586
>>  libattr.i586
>>  libcap.i586
>>  libgcc.i586
>>  libogg.i586
>>  libsndfile.i586
>>  libstdc++.i586
>>  libxcb.i586
>>  ncurses-libs.i586
>>  nss-softokn-freebl.i586
>>  pulseaudio-libs.i586
>>  pulseaudio-utils.i586
>>  readline.i586
>>  sqlite.i586
>>  tcp_wrappers-libs.i586
>
> I'm pretty sure you're looking at it wrong.
>
> [spot velociraptor devel]$ rpm -q mesa-libGL-devel.x86_64 --requires
> /usr/bin/pkg-config
> libGL.so.1()(64bit)
> libX11-devel
> mesa-libGL = 7.5-0.14.fc11
> pkgconfig(dri2proto) >= 1.99.3
> pkgconfig(libdrm) >= 2.4.3
> pkgconfig(x11)
> pkgconfig(xdamage)
> pkgconfig(xext)
> pkgconfig(xfixes)
> pkgconfig(xxf86vm)
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(FileDigests) <= 4.6.0-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(VersionedDependencies) <= 3.0.3-1
>
> [spot velociraptor devel]$ rpm -q pulseaudio-module-x11.x86_64 --requires
> /bin/sh
> config(pulseaudio-module-x11) = 0.9.16-2.test2.fc12
> libICE.so.6()(64bit)
> libSM.so.6()(64bit)
> libX11.so.6()(64bit)
> libXtst.so.6()(64bit)
> libasyncns.so.0()(64bit)
> libc.so.6()(64bit)
> libc.so.6(GLIBC_2.2.5)(64bit)
> libdbus-1.so.3()(64bit)
> libdl.so.2()(64bit)
> libltdl.so.7()(64bit)
> libm.so.6()(64bit)
> liboil-0.3.so.0()(64bit)
> libprotocol-native.so()(64bit)
> libpthread.so.0()(64bit)
> libpulse.so.0()(64bit)
> libpulse.so.0(PULSE_0)(64bit)
> libpulsecommon-0.9.16.so()(64bit)
> libpulsecore-0.9.16.so()(64bit)
> librt.so.1()(64bit)
> libsamplerate.so.0()(64bit)
> libsndfile.so.1()(64bit)
> libspeexdsp.so.1()(64bit)
> libtdb.so.1()(64bit)
> libwrap.so.0()(64bit)
> pulseaudio = 0.9.16-2.test2.fc12
> pulseaudio-utils = 0.9.16-2.test2.fc12
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(FileDigests) <= 4.6.0-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rtld(GNU_HASH)
>
>> I also found dupllicates of NetworkManager x86_64 and .i586 and
>> others. I wanted some -devel packages but I thought only the x86_64
>> versions would be pulled in.
>>
>> How have this happened?
>
> Not sure how you managed it, but the packages themselves are correct.
>
> ~spot
>
>
> --
> fedora-devel-list mailing list
> fedora-devel-list redhat com
> https://www.redhat.com/mailman/listinfo/fedora-devel-list
>

I don't know but when I try to install one of those x86_64 packages it
pulls the i586 as dependencies. I've pointed all repo files to x86_64
and I really don't know how and why this happens?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]