[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: x86_64 packages depends on i586.



On Sat, Jul 11, 2009 at 6:18 PM, Frank Murphy<frankly3d gmail com> wrote:
> On 11/07/09 10:41, Jussi Lehtola wrote:
> <snip>
>>
>> The x86_64 repo contains some multilib packages. If you don't specify
>> the wanted architecture when installing, yum might install both 32- and
>> 64-bit versions if available. Try adding the .x86_64 arch specifier,
>> e.g. instead of
>> # yum install foo
>> perform
>> # yum install foo.x86_64
>
>
> Doesn't seem to work for wine :)
>

yum install foo
will install foo.x86_64 by default it will only install foo.i586 if
foo.x86_64 when

1) you do yum install foo and only foo.i586 is in the repo
2) yo do yum install foo.i586
3) if you set "exactarch=0" in /etc/yum.conf (default is 1 which leads
to the behavior I explained above)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]