[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NVR bugs in rawhide



On 07/14/2009 08:48 AM, Jussi Lehtola wrote:
> %dist should be used always.

As the person who invented %dist, I can assure you, this is false.

In the specific situation where a new noarch package with relatively
static content is being introduced, you have a few options:

* Use %dist
* Manually ensure that the upgrade ordering is sane (e.g. foo-1.2.3-1
(fc10), foo-1.2.3-2 (fc11), foo-1.2.3-3 (rawhide)
* Only build in rawhide and let inheritance pull it in for future
releases (doesn't work for past releases).

Admittedly, I think using %dist is easier/saner, but it isn't mandatory.

~spot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]