[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with ruby package with binary content...



On Tue, Jul 14, 2009 at 02:14:20PM -0400, Darryl L. Pierce wrote:
> Shoot, spoke way too soon. I had reset the spec file to remove where I
> had been experimenting with some fixes, and didn't remove the strip
> line. So I ran it with the changes you posted and with the strip line
> there and it worked. I removed the strip line and a different error came
> up now. The problem is now with pathing and not finding the .so file.

Okay, the pathing problem is fixed. Doing the following fixed the
problem:

---8<[snip]---
%global workdir %(mktemp -d)
...
gem install --local --install-dir %{workdir} \
            --force -V --rdoc %{SOURCE0}

cp -ra %{workdir}/* %{buildroot}%{gemdir}
---8<[snip]---

Things are now working fine with the non-stripped binaries.

-- 
Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
Virtual Machine Management - http://www.ovirt.org/
Is fearr Gaeilge bhriste ná Béarla cliste.

Attachment: pgpJ6uEUEoW8W.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]