[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Against what do I file this bug?



On 07/15/2009 01:31 AM, S.A. Hartsuiker wrote:
On 07/15/2009 01:24 AM, Matthew Woehlke wrote:
S.A. Hartsuiker wrote:
Now for my problem. Although Anaconda installed grub in the bootsector
of the fakeraid mirrored device, I never actually get to a grub prompt,
it just loads the kernel.

Um... do you mean that grub loads the latest kernel without pausing to
ask if that's what you want? Because as I understand that is intended
behavior with F11 (with F10 already, I want to say). Hold some key
during boot to get the grub menu (ctrl works well, being unused by most
BIOS's).

Ok, this is a pebkac. Apparently it's just a very short timeout now.
Keeping a key pressed after POST, but before I see any mention of grub
seems to work.


Presumably due to the possibility that grub can't find the /boot
partition.

This makes no sense. If grub was failing to find /boot, you would get a
grub error, since there would be nothing for it to boot (nor would it
find grub.conf, I think). IOW, you would get slightly farther than the
BIOS failing to find a MBR, but certainly no maintenance mode (which
implies a roughly-functional kernel and initrd).

Yes, see above.


However during the mounting stage of the boot process the /boot
partition can also not be found and I am dropped into maintance mode.

This sounds like an initrd problem to me, but I am no expert.


 Uhm, no. I am in the ''Fedora Interactive'' bit, the
/etc/rc.d/rc.sysinit at that moment.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]