[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Sage in F11



Sorry to bother the -devel list with this, but nobody on fedora-list
responded to my question, and I know there is some effort to package
Sage for Fedora.  I hope one of those packagers can help me out.

I've installed sage-4.1 on F11 using the F10 binary installation
tarball.  But when I run sage, it fails with the following error:

        /usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/sage
        ----------------------------------------------------------------------
        | Sage Version 4.1, Release Date: 2009-07-09                         |
        | Type notebook() for the GUI, and license() for information.        |
        ----------------------------------------------------------------------
        Traceback (most recent call last):
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/bin/sage-ipython", line 18, in <module>
            import IPython
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/lib/python2.6/site-packages/IPython/__init__.py", line 58, in <module>
            __import__(name,glob,loc,[])
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/lib/python2.6/site-packages/IPython/ipstruct.py", line 22, in <module>
            from IPython.genutils import list2dict2
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/lib/python2.6/site-packages/IPython/genutils.py", line 59, in <module>
            from IPython.external.path import path
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/lib/python2.6/site-packages/IPython/external/path.py", line 35, in <module>
            import md5
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/lib/python/md5.py", line 10, in <module>
            from hashlib import md5
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/lib/python/hashlib.py", line 136, in <module>
            md5 = __get_builtin_constructor('md5')
          File "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/lib/python/hashlib.py", line 63, in __get_builtin_constructor
            import _md5
        ImportError: No module named _md5

I assume I'm missing a dependency, but what is it?  Or is there something else going on?

Sage worked fine in F10.  This error occurred also with sage-4.0.2 in F11.

TIA.
-- 
                Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]