[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sage in F11



On Sunday 19 July 2009 02:05:44 pm Matthew Saltzman wrote:
> Sorry to bother the -devel list with this, but nobody on fedora-list
> responded to my question, and I know there is some effort to package
> Sage for Fedora.  I hope one of those packagers can help me out.
>
> I've installed sage-4.1 on F11 using the F10 binary installation
> tarball.  But when I run sage, it fails with the following error:
>
>        
> /usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/sage
> ----------------------------------------------------------------------
>
>         | Sage Version 4.1, Release Date: 2009-07-09                       
>         |  | Type notebook() for the GUI, and license() for information.   
>         |     |
>
>        
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/b
>in/sage-ipython", line 18, in <module> import IPython
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/l
>ib/python2.6/site-packages/IPython/__init__.py", line 58, in <module>
> __import__(name,glob,loc,[])
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/l
>ib/python2.6/site-packages/IPython/ipstruct.py", line 22, in <module> from
> IPython.genutils import list2dict2
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/l
>ib/python2.6/site-packages/IPython/genutils.py", line 59, in <module> from
> IPython.external.path import path
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/l
>ib/python2.6/site-packages/IPython/external/path.py", line 35, in <module>
> import md5
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/l
>ib/python/md5.py", line 10, in <module> from hashlib import md5
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/l
>ib/python/hashlib.py", line 136, in <module> md5 =
> __get_builtin_constructor('md5')
>           File
> "/usr/local/sage-4.1-linux-Fedora_release_10_Cambridge-x86_64-Linux/local/l
>ib/python/hashlib.py", line 63, in __get_builtin_constructor import _md5
>         ImportError: No module named _md5
>
> I assume I'm missing a dependency, but what is it?  Or is there something
> else going on?
>
> Sage worked fine in F10.  This error occurred also with sage-4.0.2 in F11.
>
> TIA.
> --
>                 Matthew Saltzman
>
> Clemson University Math Sciences
> mjs AT clemson DOT edu
> http://www.math.clemson.edu/~mjs

$ rpm -qf /usr/lib64/python2.6/lib-dynload/_md5module.so
python-2.6-9.fc11.x86_64

I'm guessing the version of python shipped with Sage is missing the native md5 
module (which is in %{_libdir}/python2.6/lib-dynload/_md5module.so on F-11).

Regards,
-- 
Conrad Meyer <cemeyer u washington edu>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]