[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: xulrunner-1.9.1.1-1.fc11.x86_64 update pulls in i586 packages



On 7/23/09 2:50 PM, Seth Vidal wrote:


On Thu, 23 Jul 2009, Matthew Woehlke wrote:

Seth Vidal wrote:
On Thu, 23 Jul 2009, Braden McDaniel wrote:
But why does yum assume that a dependency of an x86_64 package can be
satisfied by an i586 one?

Why not?

If something requires FOO and something else provides FOO - what
difference does it make if it is from another arch as long as the
arch is compatible with the system?

That only works if FOO is an executable and not a library, no?

libraries that are auto-prov'd - will get arch-specifc on their own.

Which isn't the case for gecko-libs; or for anything that's getting dlopen'd. The packaging guidelines probably need to raise the visibility of this issue.

--
Braden McDaniel                      e-mail: <braden endoframe com>
<http://endoframe.com>               Jabber: <braden jabber org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]