[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fedora 11 worst then ever release



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Sun, 26 Jul 2009, Björn Persson wrote:

Ralf Corsepius wrote:
On 07/26/2009 02:37 PM, Seth Vidal wrote:
On Sat, 25 Jul 2009, Alan Cox wrote:
"all of my system has a wrong openssl version"

all these symptoms sound like your upgrade went horribly wrong. I've
seen preupgrade mash up a box by half upgrading like that. It's the main
reason
I don't think preupgrade is actually safe to use yet.

Preupgrade's process is to depsolve - using the same method anaconda
does, download the pkgs it solves out. Put them in a cachedir. Download
a kernel and an initrd, Setup a ks.cfg. then reboot the machine and
allow anaconda to do the install.

Specific issues we've had with preupgrade are related to not being able
to find a mirror and/or not being able to get pkgs.

Mine were
* preupgrade running out of diskspace on / when trying to fill
/var/cache/yum (my "/"'s tend to be minimized/small)

You're not blaming Preupgrade for the partition being too small, are you? If
you want a small root partition you should put /var/cache/yum on another
partition.

Do you mean Preupgrade didn't handle the lack of disk space well?

* anaconda failing during reboots due not being able to process fstab
correctly (FC11's anaconda misparses fstab and is unable able to process
bind-mounts nor nfs-mounts).

Bind mounts are fixed, as far as I know:
https://bugzilla.redhat.com/show_bug.cgi?id=496406

For NFS mounts, I believe it's fixed in commit
40728ffcc1e32eb6b5ccc0cd3b3ddb23216cf199, which was on June 7th.  That should
carry over NFS mounts listed in /etc/fstab if you are doing an upgrade.

* anaconda's depsolving failed when upgrading an FC10 + FC10-updates
system due to NEVR issues.

If you have any details of the failure, it would help.  Anaconda relies on yum
to do depsolving and yum relies on correctly configured yum repositories to
provide the information to do depsolving.

If you have details, please file a bug for anaconda.


Those would be Anaconda issues, not Preupgrade issues – which makes them all
the more serious.

- -- David Cantrell <dcantrell redhat com>
Red Hat / Honolulu, HI

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkptPBYACgkQ5hsjjIy1VkkFlACeNHFf5Tx8Ief3O1qjFgSrYPEm
GBkAnj4Guybso65om2SV88cQb+vU2JiC
=uTAM
-----END PGP SIGNATURE-----

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]