[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: License change for ghostscript



On Friday 31 July 2009, Tim Waugh wrote:
> Beginning with the 8.70 release, Ghostscript will be licensed as GPLv3+.

This might cause problems for a bunch of packages.

$ repoquery --repoid=rawhide --whatrequires --alldeps ghostscript ghostscript-
gtk --qf="%{NAME}: %{LICENSE}" | grep -vP '\bGPL(v3|\S*\+)' | sort

I'm pretty sure that not all these are problems (I haven't checked license 
compatibility of non-GPL licenses with GPLv3+ nor how exactly they use 
ghostscript), and on the other hand some might have been problems also with 
the current GPLv2 ghostscript, but anyway it's a start for a checklist.

baekmuk-ttf-fonts-ghostscript: Baekmuk
cjkuni-fonts-ghostscript: Arphic
hevea: QPL
HippoDraw: GPLv2
ImageMagick: ImageMagick
libgnomeprint22: LGPLv2+ and BSD
lilypond: GPLv2
printer-filters: Public Domain
redhat-lsb: GPLv2
tetex-prosper: LPPL
tgif: QPL
transfig: MIT
xournal: GPLv2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]