[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F11: plymouthd hides important (debug) messages from initrd execution



On Thu, Jun 04, 2009 at 07:13:54PM +0300, Pasi Kärkkäinen wrote:
> On Wed, Jun 03, 2009 at 02:14:11PM +0300, Pasi Kärkkäinen wrote:
> > On Mon, Jun 01, 2009 at 08:15:48AM +0300, Pasi Kärkkäinen wrote:
> > > Hello.
> > > 
> > > Yesterday I installed latest F11/rawhide. The default installed kernel
> > > (2.6.29 something) works fine. 
> > > 
> > > I compiled custom 2.6.30-rc6 kernel, and created initrd for it, and tried
> > > booting it. 
> > > 
> > > Booting process gets stuck at "creating initial device nodes". 
> > > 
> > > Any ideas? I assume that's during initrd execution.. 
> > > Something missing from my kernel config? 
> > > 
> > > Any tips would be appreciated. 
> > 
> > Has anyone else seen this problem? 
> > 
> 
> I edited the initrd image, and added some debug echos. 
> The command that hangs the initrd execution is this:
> 
> daemonize --ignore-missing /bin/plymouthd
> 
> Any ideas? 
> 

Ok.. After I disabled every call to plymouthd from initrd init script I
figured out the problem was not related to plymouthd at all.

The problem here is plymouthd seems to _hide_ everything that happens after it
has been started.. and thus prevents important stuff from being seen and the
real problems from being easily determined. 

-- Pasi


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]