[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: More mock problems



Kevin Kofler <kevin kofler chello at> writes:

> You need these: http://infrastructure.fedoraproject.org/builder-rpms/ and
> python-hashlib from EPEL.

These won't install cleanly on an existing CentOS 5.3 builder,
net-snmp is older than the one in CentOS updates.

[root builder1 ~]# rpm -q rpm net-snmp
rpm-4.4.2.3-9.el5
net-snmp-5.3.2.2-5.el5
[root builder1 ~]# yum install rpm
Loaded plugins: fastestmirror, priorities, versionlock
Loading mirror speeds from cached hostfile
Reading version lock configuration
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: rpm = 4.4.2.3-9.el5 for package: rpm-python
--> Processing Dependency: rpm = 4.4.2.3-9.el5 for package: rpm-build
--> Processing Dependency: rpm = 4.4.2.3-9.el5 for package: rpm-libs
---> Package rpm.x86_64 0:4.6.0-4.0.mitr.1.el5 set to be updated
--> Processing Dependency: liblua-5.1.so()(64bit) for package: rpm
--> Running transaction check
---> Package lua.x86_64 0:5.1.2-1.el5 set to be updated
---> Package rpm-python.x86_64 0:4.6.0-4.0.mitr.1.el5 set to be updated
---> Package rpm-libs.x86_64 0:4.6.0-4.0.mitr.1.el5 set to be updated
---> Package rpm-build.x86_64 0:4.6.0-4.0.mitr.1.el5 set to be updated
--> Processing Dependency: librpm-4.4.so()(64bit) for package: net-snmp
--> Processing Dependency: librpmio-4.4.so()(64bit) for package: net-snmp
--> Running transaction check
---> Package net-snmp.x86_64 1:5.3.2.2-5.el5_3.1 set to be updated
--> Processing Dependency: net-snmp-libs = 1:5.3.2.2-5.el5_3.1 for package: net-snmp
--> Processing Dependency: librpm-4.4.so()(64bit) for package: net-snmp
--> Processing Dependency: librpmio-4.4.so()(64bit) for package: net-snmp
--> Running transaction check
---> Package net-snmp-libs.x86_64 1:5.3.2.2-5.el5_3.1 set to be updated
--> Processing Dependency: librpm-4.4.so()(64bit) for package: net-snmp
--> Processing Dependency: librpmio-4.4.so()(64bit) for package: net-snmp
--> Finished Dependency Resolution
1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 from update has depsolving problems
  --> Missing Dependency: librpmio-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (update)
1:net-snmp-5.3.2.2-5.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: librpm-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (update)
1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 from update has depsolving problems
  --> Missing Dependency: librpm-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (update)
Error: Missing Dependency: librpmio-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (update)
Error: Missing Dependency: librpm-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (update)

-- 
Arnaud


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]