[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: More mock problems



Kevin Kofler wrote:
Fernando Lopez-Lezcano wrote:

On Wed, 2009-04-29 at 00:40 +0200, Kevin Kofler wrote:
Neal Becker wrote:
rpmdb: Program version 4.7 doesn't match environment version 4.5
You need at least RPM 4.6 on the host systems to build Rawhide packages,
that's at least F10 + updates. All the Fedora builders are running a
custom build of RPM 4.6 on the EL5 hosts.
Is this available anywhere? My build host is EL5 and I'm finding it
impossible to build F11 packages there....

You need these: http://infrastructure.fedoraproject.org/builder-rpms/ and
python-hashlib from EPEL.
I'm not able to install the packages at builder-rpms
I'm running RHEL5 x86_64
1) upgrade to latest RHEL5 - reboot
2) added /etc/yum.repos.d/builder-rpms.repo:
[builder-rpms]
name=builder-rpms
description=New rpm and yum in order to use mock on el5 to build f11 and later packages
baseurl=http://infrastructure.fedoraproject.org/builder-rpms/x86_64/

3) yum upgrade - the only package I was able to successfully upgrade was yum - yum upgrade yum - everything else fails like this:
1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 from installed has depsolving problems
--> Missing Dependency: librpmio-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (installed)
1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 from installed has depsolving problems
--> Missing Dependency: librpm-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (installed) rpm-devel-4.6.0-4.0.mitr.1.el5.x86_64 from builder-rpms has depsolving problems --> Missing Dependency: popt-devel is needed by package rpm-devel-4.6.0-4.0.mitr.1.el5.x86_64 (builder-rpms) Error: Missing Dependency: librpm-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (installed) Error: Missing Dependency: popt-devel is needed by package rpm-devel-4.6.0-4.0.mitr.1.el5.x86_64 (builder-rpms) Error: Missing Dependency: librpmio-4.4.so()(64bit) is needed by package 1:net-snmp-5.3.2.2-5.el5_3.1.x86_64 (installed)

I cannot find popt-devel anywhere in the rhel or epel repos. Do I need to install these rpms manually with rpm rather than with yum?
        Kevin Kofler


Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]