[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/polkit-gnome/devel polkit-gnome.spec, NONE, 1.1 .cvsignore, 1.1, 1.2 sources, 1.1, 1.2



Am Montag, den 08.06.2009, 20:47 +0000 schrieb David Zeuthen: 
> Author: davidz

[snipped]

> --- NEW FILE polkit-gnome.spec ---
> Summary: PolicyKit integration for the GNOME desktop
> Name: polkit-gnome
> Version: 0.92
> Release: 1%{?dist}
> License: LGPLv2
> URL: http://www.freedesktop.org/wiki/Software/PolicyKit
> Group: Applications/System
> Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.bz2
> BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
> BuildRequires: gtk2-devel
> BuildRequires: polkit-devel >= 0.92
> BuildRequires: desktop-file-utils
> 
> # for /usr/share/gnome/autostart
> Requires: gnome-session

Great! This adds
gnome-session: 1.8 MB
control-center: 7.1 MB
GConf2: 5,5 MB
gnome-keyring: 2,3 MB
gnome-vfs2: 3.1 MB

You added at least ~ 22,8 MB overhead just for directory ownership,
although I asked you to _not_ do this. I think users of alternative
desktops and the maintainers of their spins will not be amused. Last
week you told me, that a one advantage of the new polkit is that no
longer requires GConf2, but now it's dragged in again.

> %description
> polkit-gnome provides an authentication agent for PolicyKit
> that matches the look and feel of the GNOME desktop.
> 
> %prep
> %setup -q
> 
> %build
> %configure --enable-gtk-doc
> make

Still no parallel build, only one of several problems. I already pointed
that out during the so called "review" [1] and I find it sad to see you
don't give anything about feedback, good advice and not even the
packaging guidelines.

Regards,
Christoph

[1] https://bugzilla.redhat.com/show_bug.cgi?id=502920


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]