[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mono-2.4 and ppc64 status



On Wed, Jun 3, 2009 at 1:28 PM, SmootherFrOgZ wrote:
> On Mon, Apr 20, 2009 at 11:36 PM, Toshio Kuratomi wrote:
>> Mono-2.4 has been built for ppc64 in F11 and devel.  So people should be
>> able to start rebuilding packages to include ppc64 as well as the other
>> arches.  There's a few wrinkles to watch out for:
>>
>> 1) Packages with dependencies will have to be built in dependency order.
>>  For instance, a lot of packages depend on the gtk-sharp2 bindings and
>> those haven't been built yet.
>>
>> 2) Because of the imminent release of F11 we're in a freeze state.  This
>>  means getting dependencies into the Fedora11 buildroot will require
>> people to request tagging explicitly.  This also means that if you
>> rebuild your package for F11 with ppc64 support and later you have to
>> get this package tagged into the release, all of the packages it depends
>> on will need to be tagged in as well (otherwise your ppc64 build will
>> have broken deps).
>>
>> With these in mind, I'd recommend people start rebuilding their mono
>> packages on ppc64 in the devel branch.  Keep track of the dependency
>> chain you encounter.  Then perform your builds in the Fedora 11 branch
>> as updates after the release.  I'm not a mono-sig member, though, so if
>> you guys decide something else makes sense, just be sure to come up with
>> a plan so we don't release with a bunch of broken dependencies.
>>
>
> Sound like I forgot to update this thread.
> Well,
> All packages which should depend on gtk-sharp2  and gnome-sharp has
> been rebuilt (list below).
> If i missed some please, step up or feel free to build them if you have Acls.
>
> list
> ----
> gnome-sharp-2_24_0-4_fc11
> gtksourceview2-sharp-1_0-5_svn89788_3_fc11
> gecko-sharp2-0_13-3_fc11
> webkit-sharp-0_2-2_fc11
> monosim-1_3_0_2-3_fc11
> avahi-0_6_25-2_fc11
> mono-addins-0_4-7_20091702svn127062_1_fc11
> gmime-2_4_3-5_fc11
> bless-0_6_0-3_fc11
> dbus-sharp-0_63-12_fc11
> themonospot-0_7_1_1-3_fc11
>
> ndesk-dbus-0_6_1a-5_fc11
> gnome-subtitles-0_8-8_fc11
> gnome-desktop-sharp-2_26_0-3_fc11
> evolution-sharp-0_20_0-2_fc11
> lat-1_2_3-7_fc11
> gsf-sharp-0_8_1-10_fc11
> mono-tools-2.4-9.fc11
> bareftp-0:0.2.2-2.fc10.i386
> gtk-sharp-1_0_10-23_fc11
> ndesk-dbus-glib-0_4_1-5_fc11
>
> beagle-0.3.9-8.fc11
> notify-sharp-0.4.0-0.7.20080912svn.fc11
> gnome-keyring-sharp-1.0.1-0.3.115768svn.fc11
> podsleuth-0.6.3-3.fc11
> tasque-0.1.8-3.fc11
> tomboy
> muine
> f-spot
>
> ipod-sharp-0.8.1-3.fc11
> mono-zeroconf-0.7.6-9.fc11
> gnome-do-0.8.1.3-6.fc11
> giver-0.1.8-5.fc11
> gbrainy-1.1-4.fc11
>
>

gnome-guitar is missing which I rebuilt a while ago (before your email).

I just saw that the new gnome-sharp and gtk-sharp2 is not in F-11
repos although they were in the buildroot override. This caused
dependency breakage. I also can't find them on bodhi. What is going
on?

Orcan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]