[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: unable to include capability.h



On Fri, Jun 12, 2009 at 01:48:15PM +0200, Daniel Lezcano wrote:
> Hi,
> 
> I hope this is the right mailing list ...
> 
> I installed a f11 and tried to compile a simple program:
> 
> #include <sys/capability.h>
> int main(int argc, char *argv[])
> {
> return 0;
> }
> 
> But the compilation fails with the error:
> 
> In file included from /usr/include/sys/capability.h:23,
> from myinclude.c:1:
> /usr/include/stdint.h:41: error: conflicting types for ?int64_t?
> /usr/include/linux/types.h:98: note: previous declaration of ?int64_t? 
> was here
> /usr/include/stdint.h:56: error: conflicting types for ?uint64_t?
> /usr/include/linux/types.h:96: note: previous declaration of ?uint64_t? 
> was here
> make: *** [myinclude] Error 1
> 
> Is there a trick for that or is it a bug ?

Adding  #include <sys/types.h>  seems to fix it, so I reckon its a bug in
libcap-devel's header files.

Regards,
Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]