[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: unable to include capability.h



Kyle McMartin wrote:
On Fri, Jun 12, 2009 at 03:02:39PM +0200, Daniel Lezcano wrote:
Grumf ! that's annoying :(

Thank you very much for your quick answer ! :)

As I only need the CAP_SYS_BOOT, I will define it manually in the source code and will remove the include, that's ugly but anyway... :/

As I understood, the fix in the kernel conflicts with the workaround in userspace, right ? I was wondering if I should notify this to the maintainer of the libcap or is it already known ?


Someone else suggested including <sys/types.h> first, which should work
around it. That's what GNU coreutils did... (a change in the include
ordering broke it.)
Ah yes, I prefer this workaround, it is cleaner.
Thanks for the the trick, I tested it and that solved the issue.
Which release are you seeing this on... F-11?
Correct. I tried with different distro lenny, ubuntu 8.04, fedora 10, opensuse 11 and I hadn't this problem.

Thanks.
    -- Daniel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]