[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

!Help Development of WPA_SUPPLICANT



Hi,
Help !,
I want to setup a debug build of wpasupplicant so that i can Trace PEAP - MSCHAP v2 protocol for my study,

so i have installed Fedora release 10 (Cambridge),
the wpa supplicant works fine by default which come with CD,

I downloaded wpa_supplicant-0.6.4-2.fc10.src.rpm,
and extracted it to a folder,

[root localhost wpa_supplicant]# make
[root localhost wpa_supplicant]# make install
$mkdir -p /usr/local/sbin/
$for i in wpa_supplicant wpa_passphrase wpa_cli; do cp -f $i /usr/local/sbin/$i; done
[root localhost wpa_supplicant]#


but if give command "ps -ef | grep "wpa"

i can see process running from /usr/sbin
but files copied during make install was to /usr/local/sbin/,
So i copied from /usr/local/sbin/wpa to /usr/sbin,

In network-manager applet the wireless is showing up.

Below is the output of few command's might help you answer my problem,








[root localhost wpa_supplicant]# nm-tool

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath5k_pci
  State:             unavailable
  Default:           no
  HW Address:        00:0F:B5:35:09:46

  Capabilities:
    Supported:       yes

  Wireless Settings
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points

--------------------------------------------------------------------------------------------

[root localhost wpa_supplicant]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"UTStarcom" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated  
          Tx-Power=23 dBm  
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B  
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

---------------------------------------------------------------------------------------------------------

[root localhost wpa_supplicant]# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:0F:B5:35:09:46 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

-------------------------------------------------------------------------------------
[root localhost wpa_supplicant]# cat /etc/init.d/wpa_supplicant
#!/bin/bash
# Source function library.
. /etc/rc.d/init.d/functions
# Source networking configuration.
. /etc/sysconfig/network

exec="/usr/sbin/wpa_supplicant"
prog=$(basename $exec)
conf="/etc/wpa_supplicant/wpa_supplicant.conf"
lockfile=/var/lock/subsys/$prog

[ -e /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog

start() {
     echo -n $"Starting $prog: $conf, $INTERFACES, $DRIVERS"
    daemon $prog -c $conf $INTERFACES $DRIVERS -B $OTHER_ARGS
    retval=$?
    echo
    [ $retval -eq 0 ] && touch $lockfile
    return $retval
}

----------------------------------------------------------------------------------------
[root localhost wpa_supplicant]# cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

------------------------------------------------------------------------------------------
[root localhost wpa_supplicant]# cat /usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
[D-BUS Service]
Name=fi.epitest.hostap.WPASupplicant
Exec=/usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -dddt -u -f /var/log/wpa_supplicant.log
User=root
[root localhost wpa_supplicant]#
------------------------------------------------------------------------------------------

[root localhost wpa_supplicant]# lshal

udi = '/org/freedesktop/Hal/devices/net_00_0f_b5_35_09_46'
  info.capabilities = {'net', 'net.80211'} (string list)
  info.category = 'net.80211'  (string)
  info.parent = '/org/freedesktop/Hal/devices/pci_168c_13'  (string)
  info.product = 'WLAN Interface'  (string)
  info.subsystem = 'net'  (string)
  info.udi = '/org/freedesktop/Hal/devices/net_00_0f_b5_35_09_46'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'net'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1e.0/0000:04:00.0/0000:05:00.0/net/wlan0'  (string)
  net.80211.mac_address = 67464661318  (0xfb5350946)  (uint64)
  net.address = '00:0f:b5:35:09:46'  (string)
  net.arp_proto_hw_id = 1  (0x1)  (int)
  net.interface = 'wlan0'  (string)
  net.linux.ifindex = 5  (0x5)  (int)
  net.originating_device = '/org/freedesktop/Hal/devices/pci_168c_13'  (string)
  net.physical_device = '/org/freedesktop/Hal/devices/pci_168c_13'  (string)

--------------------------------------------------------------------------------------------------------------------



Please can some one explain how to setup wpa_supplicant from my compiled one,
Why is it crashing,



Thank & Regards
Harsha Krishne Gowda






--
ಇಂತಿ
ಹರ್ಷ ಕೃ ಗೌಡ


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]