[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: X11 on intel (rawhide)





On Tue, Jun 23, 2009 at 14:12, Paul <paul all-the-johnsons co uk> wrote:
Hi,

Following the last official rawhide update (21st was it?), my desktop
has been hosed.

I've updated to the latest xorg-server and intel drivers (plus a few
others) as well as gdm and anything else I can think off. All updates
have been pulled from koji between 4pm and 10.30pm (UK, GMT)

All I'm now getting is gdm failing to start (it shows a box where the
usernames are normally, but it's blank, then restarts X).

When I look at the logs, I'm seeing the following at the bottom
(xorg.0.log)

Backtrace
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x80a3afb]
1: /usr/bin/Xorg [0x80a71b5]
2: [0xd09410]
3: /usr/lib/libdrm_intel.so.1 [0xe44750]
4: /usr/lib/libdrm_intol.so.1.(drm_intel_bufmgr_destroy+0xf)[0xe412bf]
5: /usr/lib/xorg/modules/drivers/intel_drv.so [0xf80132]
6: /usr/bin/Xorg [0x80fbdfe]
7: /usr/bin/Xorg [0x80c4cc5]
8: /usr/bin/Xorg [0x80b200c]
9: /usr/lib/xorg/modules/extensions/libextmod.so [0x1753a1]
10:/usr/bin/Xorg [0x816f1a2]
11:/usr/bin/Xorg [0x80e4bc0]
12:/usr/bin/Xorg [0x81a9459]
13:/usr/bin/Xorg [0x80e1fc2]
14:/usr/lib/xorg/modules/extensions/libglx.so [0x2792ba]
15:/usr/bin/Xorg [0x8063238]
16:/lib/libc.so.6 (__libc_start_main+0xe6) [0x8c0a66]
17:/usr/bin/Xorg [0x8062d91]

Segmentation fault at address 0xfa4

Chipset 965GM

Any ideas on what can be causing gdm/x to behave like this and more
over, how do I fix it?


I also have a 965GM. For the last six months the intel driver has been pretty flaky with it.

My current working config is with

2.6.30-6.fc12.i686.PAE
intel driver 2.7.0-6.fc12
xorg-x11-server-common-1.6.1.901-5.fc11.i586 (et al)
libdrm-2.4.12-0.1.fc12.i586

(note that I have to boot with mem=3G on a 4 gig machine, running in 32 bit, not 64 bit)

The newer 2.6.31 kernels work but show

Jun 22 18:57:23 localhost kernel: [drm:drm_wait_vblank] *ERROR* failed to acquire vblank counter, -22

(rant: why anyone would put debugging in a vertical blanking area i don't know, but it sure fills up the log quickly)

The newer intel drivers past 2.7.0-6 don't work. Newer versions of xorg are also broken for me. Sometimes booting with nomodeset also helps, but again the recent versions have been painful for that.

Things have been quite unstable for about six months for this chip, so don't expect anything to change quickly.

darrell

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]