[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: update mechanism for new releases



Peter Robinson wrote:
I've never attempted an RPM-based update from e.g. Fedora 10 to
Fedora 11. How well does that work out for regular Fedora users?
Lot's of people will tell you that it works fine. However, this is not
a supported path for upgrade. Users should use Pre-Upgrade instead.
See:
=> http://fedoraproject.org/wiki/Category:PreUpgrade
=> http://fedoraproject.org/wiki/Interviews/PreUpgrade

Well its not supported completely, the simple fact that a lot of
people use it means that its supported within certain constraints.

I think you confuse "supported" and "functional". Upgrade via yum is mostly /functional/. It is "(officially) supported" exactly to the extent that you get to keep the pieces. If you are lucky, people /might/ help you put them back together :-).

<aside>
Last weekend I finished yum upgrade 10 -> 11 on my Asus EEE... and it /did/ leave me with pieces. Specifically, I had to find a Live stick to boot to run fsck, since at one point I tried to boot to a partly-updated system with filesystem errors, and got into a situation where neither of "continue or give root password for maintenance" worked (any key press would just repeat the message, so I couldn't "give root password for maintenance").

Lesson here is probably 'don't reboot when upgrade is only partly complete' :-). Which I normally wouldn't do except ssd is so dang slow it took two days to do all updates. Also... *yum upgrade isn't supported* ;-).

That said, my first (on a VM) 10 -> 11 via yum went smoothly, and the other one did up until the IDE path on the (rather old) machine decided to pack it in. Finished updates, went to reboot, and got nothing but ATA errors. So... I bought a new machine, moved the drive, and it's now just fine. (I had to nuke xorg.conf, and, well, it shouldn't be that hard to fix NIC device assignment, but these were problems due to swapping out the entire machine from under the installation, not the upgrade :-).)

So... 60% "smooth sailing" rate isn't terrible, especially since I /was/ able to reassemble all the pieces I got to keep without too much trouble.
</aside>

The problem with preupgrade is that it needs user interaction and a
lot of space. It downloads the distro update locally, reboots the
machine and then runs anaconda.

...which is why I couldn't use it on the Asus :-). (To my pleasant surprise, I somehow have /more/ free space now, but still only about 900 MB.)

--
Matthew
Please do not quote my e-mail address unobfuscated in message bodies.
--
Do you know where your towel is?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]