[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: TeX Live 2008 available for testing



On Sat, Jun 27, 2009 at 03:26:53PM +0100, José Matos wrote:
> On Saturday 27 June 2009 13:41:42 Jindrich Novy wrote:
> > Note that it is in testing state so (many) bugs could occur. There are
> > possible clashes with applications packaged separately (such as
> > dvipdfmx, etc.) so we may want to discuss these conflicts with
> > respective fedora package maintainers to fix them. In case you are a
> > maintainer of such package please send me an email to jnovy redhat com
> > so that we can sort it out on the TeX Live side (packages maintained
> > separately are preferred).
> >
> > Thanks,
> > Jindrich
> 
> This is what I get after yum update
> 
> Error: Missing Dependency: tetex >= 3.0 is needed by package 
> jadetex-3.13-5.fc11.noarch (installed)
> Error: Missing Dependency: tetex-latex >= 3.0 is needed by package 
> jadetex-3.13-5.fc11.noarch (installed)
> Error: Missing Dependency: tetex is needed by package texinfo-
> tex-4.13a-2.fc11.i586 (installed)
> Error: Missing Dependency: tetex-dvips is needed by package docbook-utils-
> pdf-0.6.14-16.fc11.noarch (installed)
> Error: Missing Dependency: libkpathsea.so.4 is needed by package 
> dvipdfm-0.13.2d-40.fc11.i586 (installed)
> Error: Missing Dependency: tetex-latex is needed by package 
> a2ps-4.14-8.fc11.i586 (installed)
> Error: Missing Dependency: tetex-dvips is needed by package 
> a2ps-4.14-8.fc11.i586 (installed)
> Error: Missing Dependency: libkpathsea.so.4 is needed by package evince-
> dvi-2.26.2-1.fc11.i586 (installed)
> Error: Missing Dependency: tetex-latex is needed by package R-
> devel-2.9.0-2.fc11.i586 (installed)
> Error: Missing Dependency: tetex-fonts is needed by package 
> a2ps-4.14-8.fc11.i586 (installed)
> 
> A missing Provides?

Currently texlive correctly obsoletes all the old tetex* stuff. I
thought it is a good idea to not to provide the old tetex bits any more
because we have virtual provides for them like tex(latex) or tex(dvips) for
a long time. So it is better to fix the requires on the packages side
requiring TeX. Note that this will work even with the current old
texlive-2007 present in Fedoras. Thanks for the list of packages that
needs to be fixed.

evince-dvi will need rebuild for the libkpathsea soname bump as soon
as new texlive lands in Fedora.

Jindrich


> -- 
> José Abílio
> 
> -- 
> fedora-devel-list mailing list
> fedora-devel-list redhat com
> https://www.redhat.com/mailman/listinfo/fedora-devel-list

-- 
Jindrich Novy <jnovy redhat com>   http://people.redhat.com/jnovy/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]