[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F-10 mock can't build rawhide packages



Roland McGrath <roland redhat com> writes:
>> I'm having the same problem:
>> 
>> rpmdb: Program version 4.5 doesn't match environment version 4.7
>> error: db4 error(-30972) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
>> error: cannot open Packages index using db3 -  (-30972)
>> error: cannot open Packages database in /var/lib/mock/fedora-11-x86_64/root/var/lib/rpm

> When I had those errors on rawhide itself, what was necessary was:
> 	rm -f /var/lib/rpm/__db.*
> Perhaps:
> 	rm -f /var/lib/mock/fedora-11-x86_64/root/var/lib/rpm/__db.*
> would do it?

FWIW, mock seems to work for me in a fresh-as-of-yesterday F10
installation.  If Roland's idea doesn't work, try blowing away
*everything* under /var/lib/mock and see where that gets you.

			regards, tom lane


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]