[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: repo whatrequires



On Thu, 12 Mar 2009 12:38:59 +0000, Pádraig wrote:

> I'd like to lookup in the repo what packages require a particular package.
> I can do this locally with this python script:
> http://www.pixelbeat.org/scripts/whatrequires
> 
> For example seeing what local packages require libicu...
> 
> $ whatrequires libicu
> libicu-devel-3.8-6.fc8.i386
> icu-3.8-6.fc8.i386
> boost-1.34.1-5.fc8.i386
> boost-devel-1.34.1-5.fc8.i386
> 
> I tried these to no avail:
> $ repoquery --whatrequires /usr/lib/libicudata.so.38

No package requires this path.

> $ repoquery --whatrequires libicu

It's likely that no package requires this package name in favour of
requiring a library SONAME such as libicudata.so.38
Use:

$ repoquery --alldeps --whatrequires libicu
$ repoquery --whatrequires libicudata.so.38


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]