[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: packaging wordpress plugins

On Fri, Mar 20, 2009 at 10:10:03AM +0000, Bill Crawford wrote:
> ... and yes, but that means the plugins will only work with one version or the 
> other, and that would be a random thing at build time (depending which package 
> was installed to satisfy the BR: wordpress-core).
> So, you need to have a way of making a single shared directory; although that 
> only works if the two packages are guaranteed to not introduce incompatability 
> with each other in whatever passes for an "ABI" :o)
So given that the plugin is not guaranteed to be compatible with both WP
and WP-MU at the same time, I provide the following specfile template:


Because of the standards that WordPress holds to their plugins, filling
in plugin_name, plugin_human_name, a Version, a description, and
changelog should Just Work(tm). Criticism extremely wanted since there
are some WordPress plugins I need to get in EPEL on a deadline :/

Ian Weller <ianweller gmail com>
GnuPG fingerprint:  E51E 0517 7A92 70A2 4226  B050 87ED 7C97 EFA8 4A36

Attachment: pgp5W3LTbPFaV.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]