[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pkgconfig can't find libgnomeui on F9



> This is due to pkgconfig change. Now also F-9 pkgconfig tries to check
> "Requires.private" for "pkg-config --exists". F-9 libgnomecanvas-2.0.pc
> has "gail" in Requires.private, while root.log says "gail-devel" is not
> included (note: with old pkgconfig "BR: gail-devel" was not needed)

Just to save others the trouble of searching, this appears to be the
best reference:

http://err.no/personal/blog/2008/Mar/25

I don't understand all the details, but the bottom line seems to be
that everything in both Requires and Requires.private needs to be in
Requires.  So then we need this attached patch?
? libgnomecanvas-2.20.1.1
cvs diff: Diffing .
Index: libgnomecanvas.spec
===================================================================
RCS file: /cvs/pkgs/rpms/libgnomecanvas/F-9/libgnomecanvas.spec,v
retrieving revision 1.49
diff -u -r1.49 libgnomecanvas.spec
--- libgnomecanvas.spec	8 Nov 2008 20:14:34 -0000	1.49
+++ libgnomecanvas.spec	23 Mar 2009 19:33:00 -0000
@@ -38,6 +38,7 @@
 Requires: gtk2-devel >= %{gtk2_version}
 Requires: libart_lgpl-devel >= %{libart_lgpl_version}
 Requires: libglade2-devel >= 2.6.2-6
+Requires: libgail-devel
 Requires: pkgconfig
 # for /usr/share/gtk-doc/html 
 Requires: gtk-doc

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]