[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pkgconfig can't find libgnomeui on F9



2009/3/23 Colin Walters <walters verbum org>:
>> This is due to pkgconfig change. Now also F-9 pkgconfig tries to check
>> "Requires.private" for "pkg-config --exists". F-9 libgnomecanvas-2.0.pc
>> has "gail" in Requires.private, while root.log says "gail-devel" is not
>> included (note: with old pkgconfig "BR: gail-devel" was not needed)
>
> Just to save others the trouble of searching, this appears to be the
> best reference:
>
> http://err.no/personal/blog/2008/Mar/25
>
> I don't understand all the details, but the bottom line seems to be
> that everything in both Requires and Requires.private needs to be in
> Requires.  So then we need this attached patch?

The other thing you can do if you know that gnomecanvas will not need
the gail headers and you will not be static linking to gnomecanvas
(maybe the .a isn't even installed) is to remove the gail reference
from libgnomecanvas.pc Requires.private. Or you can remove the gail
reference from Requires.private and add -lgail to Libs.private.

My take is that fixing these issues would require more granularity in
pkg-config to specify exactly what is required from another package.

http://lists.freedesktop.org/archives/pkg-config/2009-February/000411.html

--
Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]