[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Requires: %{_libdir}/pkgconfig



Dependency chaos. Some packagers have started with adding

  Requires: %{_libdir}/pkgconfig

instead of the good old "Requires: pkgconfig". Not only is this dependency
expensive -- the filelists metadata must be loaded and parsed -- it doesn't
work correctly either, because

1) package "pkgconfig" is not multilib'ed, so e.g. pkgconfig.i386 is
not available in the x86_64 repo, and hence nothing provides the
/usr/lib/pkgconfig directory, (and it would be a broken dep) but

2) a couple of other packages include %_libdir/pkgconfig by accident,
which violates the packaging guidelines. Namely:

  openchange-devel  499655
  ipod-sharp-devel  499658
  sane-backends-devel  499659
  libXScrnSaver-devel  499660
  freetype-devel  499661
  anthy-devel  499663

Since these are multilib'ed, a dependency on /usr/lib/pkgconfig
doesn't pull in pkgconfig.i386 but one of these -devel packages
instead.

[...]

Conclusively, neither "Requires: %{_libdir}/pkgconfig" nor
"Requires: pkgconfig%{_isa}" will work as expected.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]