[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 182 pending F11 stable updates. WTF?



Adam Williamson wrote:
> I don't quite see how that works...what does it achieve? Are there
> things which can work happily with either the KDE 3 or KDE 4 versions of
> kdelibs?

It allows doing things like Requires: kdelibs = 6:3.5.10, but I agree it
isn't all that useful and packages shouldn't be using that (but use
Requires: kdelibs3 = 3.5.10 if that's what they need, and more likely they
want kdelibs3 >= 3.5.n for some n, which is not encodable in a good way
with the kdelibs Provides). But the idea is to make the package suitable as
a drop-in replacement for the original unrenamed package, and I've seen
this idiom also in other compat packages. I wouldn't lose any sleep over it
if it got dropped from kdelibs3 though, packages should have fixed Requires
already by now, if they still try requiring kdelibs when they actually want
kdelibs3, they need to be fixed.

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]