[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Update -> b0rken eclipse



On Mon, 2009-05-11 at 01:18 -0400, Dimi Paun wrote:
> On Sun, 2009-05-10 at 00:25 -0400, Andrew Overholt wrote:
> > Also, why is it so hard to install with the Update
> > Manager?  I'm curious both as a Fedora maintainer and an upstream
> > person. 
> 
> OK, so this is a partial story (now that I have things working, 
> I can not easily reproduce all problems). But check this out.
> 
> Problem: you are a Java developer and need the Web Server Tools
> 
>  1. You go to Software Updates ...
>  2. There's no WST anywhere, so you click on "Manage Sites", which
>     looks something like this:
>     http://img228.imageshack.us/img228/52/screenshotavailablesoft.png
> 
>     WTF?!? Which one do I pick? You try to parse the URLs, there's
>     no "web" in there it seems.
> 
>  3. So you say, OK, let's add the site:
>     http://img219.imageshack.us/img219/2415/screenshotaddsite.png
> 
>     Great, but where do I find it, how? You go on the eclipse.org
>     site, you click around, the information is hard to find.
>     You find lots of complicated download pages, you lose a lot of
>     time finding the silly URL, finally you discover it on the
>     download page and wonder why you didn't find it the first 2-3
>     times you looked at it.
> 
>  4. You add the site, and try to install the WST. You expand it
>     and you see this:
>     http://img24.imageshack.us/img24/881/screenshotsoftwareupdat.png
> 
>     Dali? Patch Features? WTF?!? All I want are the Web tools!
> 
>  5. So you expand one more level to try to find what you're looking for:
>     http://img219.imageshack.us/img219/881/screenshotsoftwareupdat.png
> 
>     Holly crap! What do you pick from there? This would make a grown
>     man cry :) So you go and pick a few safe things that seem reasonable
>     (Java EE Developer Tools, Eclipse XML Editor and Tools, etc)
> 
>  6. Then you click "Install":
>     http://img219.imageshack.us/img219/5549/screenshotprogressinfor.png
> 
>     This is great. So it looks up dependencies, etc. But wait!
>     At the end of the install, I get a small dialog telling me that the
>     install failed due to missing dependencies (despite the dependency
>     check saying it was OK)! You parse the cryptic names, and install
>     some EMF that might seem to help. Try again. Fail! Add GFE, that    
>     might help. Fail. Similar error at the _end_ of the install.
> 
>     WTF? What next? Maybe instead of installing all 4 features at once,
>     lets try to do it one by one. What do you know, that works...
> 
> As I was writing this, I realized that maybe some of the problems stem
> from the fact that I started with a non-pristine .eclipse dir.
> 
> So I've erased it, and tried again:
>   - add the WST project site
>   - select the 4 components I am interested in
>   - click install:
>     http://img140.imageshack.us/img140/4483/screenshotinstall.png
> 
> What am I supposed to do next?
> 
> The whole thing is an interaction disaster. When I add a site it
> should automatically read some metadata and add any dependencies
> automatically, etc, etc. This is DLL/RPM/you-name-it hell all
> over again.

I think I had similar problems.

You might want to check out a series of posts on Eclipse setup issues in
the Fedora-list list starting on November 30th, 2008.  The "solved"
thread starts on December 4th, 2008.

You might also want to check out
https://bugzilla.redhat.com/show_bug.cgi?id=474509

It gives a more concise description, but without some of the background
information. 

Once I installed Eclipse properly, everything worked perfectly,
including adding new features and updating. 

LG.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]