[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: koji breakage for F12 builds



On Wed, 2009-05-13 at 19:17 +0200, Nicolas Chauvet wrote:
> 2009/5/13 James Antill <james fedoraproject org>:
> > On Wed, 2009-05-13 at 14:15 +0100, Bastien Nocera wrote:
> >> The problem was/is that libnotify-devel requires a
> >> desktop-notification-daemon (via libnotify itself), and yum will install
> >> both packages that provide it.
> >
> >  How did you come to this conclusion?
>
> xfce4-notifyd : 12 characters
> notification-daemon:  19 characters
> Short name wins! xfce4-notifyd is picked unless something within the
> dependencies is hardcoded to notification-daemon.
> 
> And that's how xfce4 won the battle for the default desktop in the rpm world...

 Yes, but there yum is installing _one_ package for the provide ... it
later installs the other provide due to an explicit requires. But this
isn't the same thing as saying yum is installing both for the single
provide, which is what I read Bastien as saying.
 Just removing the explicit requires should fix mock, and presumably
something would be added to comps. so that the non-xfce version is
installed explicitly for installs.

 I did a "best providers" patch a few months ago now, to solve this
exact kind of problem:

http://james.fedorapeople.org/yum/patches/yum-best-providers-metadata.patch

...getting that into yum for Fedora 12 should be possible, as long as
Fedora rel-eng want it.

-- 
James Antill <james fedoraproject org>
Fedora


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]