[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Rawhide upgrade



I just upgraded yet another machine to Rawhide, but this time
mysteriously the old problem of RPM not understanding the packages
checksums resurfaced (the system was running fully updated F-10 at the
time of upgrade). The other 3 boxes went just fine, but not this one.
The only thing that's different about this system is that it is running
SELinux in enforcing mode (targeted policy). The other 3 have SELinux
disabled.

Just after selinux-policy-targeted finished painting its asterisks on
the screen, things went wrong. Every single package after that did not
get upgraded (this includes "unimportant" things such as rpm and yum),
but the cleanup did run (ergo, very few packages were left on the
system). Errors on the screen were indicating that package checksums
were wrong.

I managed to rescue the machine with a bit of by-hand hacking (rpm2cpio
on another machine is your friend), but just wanted to warn that maybe
things are not yet 100%. Not sure if people bumped into this recently...

-- 
Bojan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]