[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

dependency errors while upgrading vom F10 to Rawhide (F11)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I checked the ability to upgrade from F10 to F11 (Rawhide) directly
using yum. A couple of weeks ago, there were dependency errors with
python. These errors are not fixed until now.

In my point of view, this issue should be fixed until GA of Leonidas.

Thanks,
	Uwe

======================================================================

What I have done:

[root alberta ~]# yum --disablerepo=* --enablerepo=rawhide update

I got:

- --> Finished Dependency Resolution
sos-1.8-11.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package
sos-1.8-11.fc10.noarch (installed)
7:kdegraphics-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libdjvulibre.so.15 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
PyQt4-4.4.4-6.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
PyQt4-4.4.4-6.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
kdeedu-marble-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libgps.so.17 is needed by package
kdeedu-marble-4.2.3-1.fc10.i386 (installed)
7:kdegraphics-libs-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libexiv2.so.4 is needed by package
7:kdegraphics-libs-4.2.3-1.fc10.i386 (installed)
7:kdegraphics-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpoppler.so.3 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
6:kdelibs-4.2.3-2.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libssl.so.7 is needed by package
6:kdelibs-4.2.3-2.fc10.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package
sos-1.8-11.fc10.noarch (installed)
Error: Missing Dependency: libdjvulibre.so.15 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: libpoppler.so.3 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: libssl.so.7 is needed by package
6:kdelibs-4.2.3-2.fc10.i386 (installed)
Error: Missing Dependency: libpython2.5.so.1.0 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
Error: Missing Dependency: libexiv2.so.4 is needed by package
7:kdegraphics-libs-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: libgps.so.17 is needed by package
kdeedu-marble-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
[root alberta ~]#


So, I tried to use updates-testing to fix, but more errors appeared:

- --> Finished Dependency Resolution
sos-1.8-11.fc10.noarch from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package
sos-1.8-11.fc10.noarch (installed)
7:kdegraphics-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libdjvulibre.so.15 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
PyQt4-4.4.4-6.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpython2.5.so.1.0 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
PyQt4-4.4.4-6.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
createrepo-0.9.7-7.fc10.noarch from updates-testing has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package
createrepo-0.9.7-7.fc10.noarch (updates-testing)
kdeedu-marble-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libgps.so.17 is needed by package
kdeedu-marble-4.2.3-1.fc10.i386 (installed)
ntp-4.2.4p7-1.fc10.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libcrypto.so.7 is needed by package
ntp-4.2.4p7-1.fc10.i386 (updates-testing)
1:qt-4.5.1-10.fc10.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libssl.so.7 is needed by package
1:qt-4.5.1-10.fc10.i386 (updates-testing)
1:qt-x11-4.5.1-10.fc10.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libcrypto.so.7 is needed by package
1:qt-x11-4.5.1-10.fc10.i386 (updates-testing)
7:kdegraphics-libs-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libexiv2.so.4 is needed by package
7:kdegraphics-libs-4.2.3-1.fc10.i386 (installed)
7:kdegraphics-4.2.3-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libpoppler.so.3 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
1:qt-x11-4.5.1-10.fc10.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libssl.so.7 is needed by package
1:qt-x11-4.5.1-10.fc10.i386 (updates-testing)
6:kdelibs-4.2.3-3.fc10.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libssl.so.7 is needed by package
6:kdelibs-4.2.3-3.fc10.i386 (updates-testing)
preupgrade-1.1.0-1.fc10.noarch from updates-testing has depsolving problems
  --> Missing Dependency: python(abi) = 2.5 is needed by package
preupgrade-1.1.0-1.fc10.noarch (updates-testing)
1:qt-4.5.1-10.fc10.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libcrypto.so.7 is needed by package
1:qt-4.5.1-10.fc10.i386 (updates-testing)
Error: Missing Dependency: python(abi) = 2.5 is needed by package
sos-1.8-11.fc10.noarch (installed)
Error: Missing Dependency: libdjvulibre.so.15 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: libssl.so.7 is needed by package
1:qt-4.5.1-10.fc10.i386 (updates-testing)
Error: Missing Dependency: libcrypto.so.7 is needed by package
1:qt-4.5.1-10.fc10.i386 (updates-testing)
Error: Missing Dependency: libpoppler.so.3 is needed by package
7:kdegraphics-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package
preupgrade-1.1.0-1.fc10.noarch (updates-testing)
Error: Missing Dependency: libssl.so.7 is needed by package
1:qt-x11-4.5.1-10.fc10.i386 (updates-testing)
Error: Missing Dependency: libpython2.5.so.1.0 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
Error: Missing Dependency: libexiv2.so.4 is needed by package
7:kdegraphics-libs-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: python(abi) = 2.5 is needed by package
createrepo-0.9.7-7.fc10.noarch (updates-testing)
Error: Missing Dependency: libcrypto.so.7 is needed by package
ntp-4.2.4p7-1.fc10.i386 (updates-testing)
Error: Missing Dependency: python(abi) = 2.5 is needed by package
PyQt4-4.4.4-6.fc10.i386 (installed)
Error: Missing Dependency: libgps.so.17 is needed by package
kdeedu-marble-4.2.3-1.fc10.i386 (installed)
Error: Missing Dependency: libssl.so.7 is needed by package
6:kdelibs-4.2.3-3.fc10.i386 (updates-testing)
Error: Missing Dependency: libcrypto.so.7 is needed by package
1:qt-x11-4.5.1-10.fc10.i386 (updates-testing)
[root alberta ~]#


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIVAwUBShuqvkJXG7BUuynnAQKxUA/+I1L2mLXzS72zK1LOQFtu6O0GX9HwuCFx
PFJROClcq5aeeIBz7wJaqcxsbaRdIlTVwBziuvtSrkc2jCVOh2yftStv7Z0IGzHW
PgN4YGu90+RbPH8w4W/98FKJyOhqPCBLDb0O6Y0i1u0LQDPlq9JBq+d+g0ycOqDt
SBu2XdDzzcsbp5jOebMFjBye/MqBrXpkgeviWxQwFbvslXV7RMUyK/XoPEVWTOXw
GzxuI6khw+rvK3DwMwBAVjEoxsGzzpk+PkqfggKnDn74QgWngrDBA52dJLYtHa3M
INvXwoQH2U6cUtmQf2Gw/o5zwBEOCM1DYTy3k/KevasFixMUjCObrbWV98ojzcvq
cOXMZvCZRTykwI0qh+gqB9A93TpLl8AJq9VmFSIogvHhEmFglJpeaBuCnpHtKlzr
5Q3B/oh1WYGWmdVp/kwc3CsbKS7hTHrnYn3FFbpwdqJ7Pju82y1pMXdoEnpVgdSU
VJvX2sJRX5fPl1z5YnzrNOzJ5zzhUfn/qYk1e8tjFXMH5adoGZPSuoQYz90iInEu
Ab0CxanzvY+pbIZ9dbvVA4TyB2ENFnqmEeqhdE0Fng9iGe5jblqMvMdq+vNvtl5z
WrTyHy1cjclClL5ZH/a2WmJ8AfPx9ISKHZ53kD8vSAGBAphSWaxZaKbrxPEEWjr6
D3IZz8fJm1Q=
=78wC
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]