[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dependency errors while upgrading vom F10 to Rawhide (F11)





On Tue, 26 May 2009, Adam Williamson wrote:

On Tue, 2009-05-26 at 21:17 +0200, Uwe Kiewel wrote:

We don't consider issues which would cause upgrading from release to
release via yum to be blockers, but issues which would cause upgrading
via preupgrade to fail usually would be.

So, I have to google about preupgrade. It's the first time I hear about.
I did the upgrade via yum since F5 successfuly...

Sure. As I said, practically speaking, it's likely to work in many
cases. It's just that if you talk to the people most involved in
implementing it (Seth) and testing it (Will) they will tell you that

(Will has done most of the implementing in the last MANY releases of preupgrade)

doing live upgrades via yum can't really ever be 100% safe for various
reasons, but preupgrade can get very close and is useful in all the same
cases. So their position is, we support preupgrade, we don't support
yum. If yum works, great, if it doesn't, you can bug people to fix
whatever it stopping it working, but it's not 'required' by any policy
or guideline.

The biggest problem you are likely to run into with a yum-based upgrade is situations where updating something takes out the foundation on which yum is running.

The fontconfig bug comes to mind.

If you want to run yum quasi-safely run it from a terminal, in screen.

-sv



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]