[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20091104 changes - excluding noarch packages



On Wed, 04 Nov 2009 09:06:34 -0700, Orion wrote:

> On 11/04/2009 09:04 AM, Andrew Overholt wrote:
> > * Orion Poplawski<orion cora nwra com>  [2009-11-04 10:58]:
> >> On 11/04/2009 07:47 AM, Rawhide Report wrote:
> >>> Compose started at Wed Nov  4 08:15:08 UTC 2009
> >>>
> >>> Broken deps for ppc64
> >>> ----------------------------------------------------------
> >>> 	eclipse-photran-5.0.0-0.3.200910081739.fc12.noarch requires eclipse-cdt>= 1:6.0
> >>>
> >>
> >> Is there any way to exclude a noarch package from certain arches?
> >
> > ExcludeArch
> >
> 
> I did ExcludeArch: ppc64 and submitted a build, but it attempted to 
> build it on a ppc64 machine:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1787949
> 
> Should I just keep retrying until I get another arch?

No. If it cannot be built on ppc64, it's not noarch, but
arch-specific.

However, the previous response was correct. You can use ExcludeArch for
noarch packages, which can be built on an arbitrary arch, but would
suffer from missing install-time dependencies on specific archs.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]