[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20091104 changes - excluding noarch packages



On 11/04/2009 10:39 AM, Jesse Keating wrote:
On Wed, 2009-11-04 at 17:20 +0000, Paul Howarth wrote:
So a noarch script package that depends on its arch script interpreter
(e.g. all python and perl packages) should be arch packages?


And bash for that matter.

This is a known problem with rpm/koji.  The distinction between "noarch"
and "arch specific" is a difficult one to draw.  We do have support in
our compose tools to look up an srpm and determine whether or not a
noarch rpm has Exclude/ExclusiveArch settings (since that data doesn't
propagate to the noarch rpm itself).  What we don't have just yet is
code in koji to detect a noarch build that has Exclude/ExclusiveArch
settings and avoid sending said build to one of those arches.



So, I managed to do a build with:

BuildArch: noarch
ExcludeArch: ppc64

If that gets tagged, it will get excluded from the ppc64 repo?

--
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  orion cora nwra com
Boulder, CO 80301              http://www.cora.nwra.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]