[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: odd file requires



2009/11/9 Todd Zullinger <tmz pobox com>:
> Seth Vidal wrote:
>> Take a look through, see if you see a package you're responsible for
>> and, if you can, figure out a way to not need the file-requires.
>
> In the case of puppet (and probably some of the others listed in the
> /usr/share/emacs/site-lisp section), puppet provides an emacs file,
> but it also owns %{_datadir}/emacs so as not to require emacs.  AFAIK,
> since puppet provides this file, the filelists don't need to be
> downloaded to resolve the dep.  At least, I don't recall ever seeing
> it download them when I've installed or updated puppet.

Note that actually the problem raised in Seth's list is actually the
ftnchek package doing a Requires: /usr/share/emacs/site-lisp

Reported, with a patch here:

https://bugzilla.redhat.com/show_bug.cgi?id=533906

Jonathan.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]