[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: odd file requires



On Mon, 2009-11-09 at 11:58 -0500, Seth Vidal wrote:
> Hey folks,
>   I put together this list for things I'd like to work on for f13. It's a 
> list of packages with a file-requires that falls outside of *bin/* and 
> /etc/* and then the provider(s) for those files.
> 
> http://skvidal.fedorapeople.org/misc/non-primary-file-reqs-and-what-requires-them.txt
> 
> I've gone through some of them and I'm looking for where we can clean up a 
> few more.
> 
> Take a look through, see if you see a package you're responsible for and, 
> if you can, figure out a way to not need the file-requires.
> 
> this helps our users b/c if we don't need to get the filelists to resolve 
> the dependency then they don't use up the bandwidth.

The qemu/gpxe-roms-qemu ones were added because we were moving a file
from gpxe-roms to gpxe-roms-qemu.

Leaving it as a package requires means hard-coding knowledge in qemu
about which version of gpxe-roms-qemu provides which roms. IMHO, the
file requires makes more sense.

Cheers,
Mark.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]