[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/iptstate/F-12 iptstate.spec,1.21,1.22



2009/11/11 Michael Schwendt <mschwendt gmail com>:
> On Wed, 11 Nov 2009 09:17:58 +0000 (UTC), Paul wrote:
>
>> Author: stingray
>>
>> Update of /cvs/pkgs/rpms/iptstate/F-12
>
>>  %changelog
>> +* Tue Nov 10 2009 Paul P. Komkoff Jr <i stingr net> - 2.2.2-2
>> +- rebuild for libnetfilter_conntrack-0.0.100
>> +
>> +* Tue Nov 10 2009 Thomas Woerner <twoerner redhat com> 2.2.2-1
>> +- new version 2.2.2
>> +- removed upstream strerror patch
>> +- fixed package description (rhbz#140516)
>> +
>
> Caution! Dude, you should slow down quite a bit and give all this a second
> thought.
>
> You have not yet committed and built the new libnetfilter_conntrack
> upgrade for F-12. Rebuilding the other packages for F-12 won't work
> correctly because of that. They are built against the old library.
>
> Take your time. Update your cvs working-directory with "cvs up -d" to get
> the F-12 branch, then follow Fedora procedures for this ABI-incompatible
> library upgrade (which means to request a koji buildroot override tag from
> Fedora Release Engineering so the new libnetfilter_conntrack for F-12 will
> be made available in the koji buildroot _prior_ to pushing it into the
> stable updates repository. That way you can prepare all rebuilds without
> pushing any incompatible upgrades into the stable repo). If you need help,
> ask your sponsor, or ask on this list.

Oops, too late!

[chris yoda ~]$ sudo yum update
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dhclient.x86_64 12:4.1.0p1-4.fc11 set to be updated
---> Package f-spot.x86_64 0:0.6.1.3-1.fc11 set to be updated
---> Package f-spot-screensaver.x86_64 0:0.6.1.3-1.fc11 set to be updated
--> Processing Dependency: libnetfilter_conntrack.so.1()(64bit) for
package: iptstate-2.2.1-5.fc11.x86_64
---> Package libnetfilter_conntrack.x86_64 0:0.0.100-1.fc11 set to be updated
---> Package libvorbis.x86_64 1:1.2.0-9.fc11 set to be updated
---> Package libvorbis-devel.x86_64 1:1.2.0-9.fc11 set to be updated
--> Finished Dependency Resolution
iptstate-2.2.1-5.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: libnetfilter_conntrack.so.1()(64bit) is
needed by package iptstate-2.2.1-5.fc11.x86_64 (installed)
Error: Missing Dependency: libnetfilter_conntrack.so.1()(64bit) is
needed by package iptstate-2.2.1-5.fc11.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Is there any way to sanity-check pushed updates for depsolving capabilities?

-- 
Christopher Brown


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]