[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlint warnings...



On 11/15/2009 06:52 PM, Matt Domsch wrote:
On Sun, Nov 15, 2009 at 01:59:57PM -0700, Nathanael Noblet wrote:
Hello,
   So I recently posted my first package and the review. While I waited I started cleaning up more issues I found after I realized you could run rpmlint on the actual rpm and not just the spec file. I'd like the review to go as quickly as possible so I'm just trying to get all those warnings cleaned up.

   My package has a number of sub packages for various backend drivers. These subpackages basically contain a .so file for the most part however I'm getting rpmlint messages as follows

libdspam.x86_64: W: devel-file-in-non-devel-package /usr/lib64/libdspam.so

You should also see if you can build the app such that it installs its
private plugins in a subdir of %{_libdir} rather than
clutter up %{_libdir} with libraries that nothing else can use.

Yeah, there is a lib, and then dlopened backend drivers. So we have.

%{_libdir}/libdspam.so.7  (libdspam package)
%{_libdir}/dspam/libdspam-mysql_drv.so (libdspam-mysql)

For each backend driver.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]