[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlint warnings...



On Mon, 16 Nov 2009 13:24:03 -0700, Nathanael wrote:

> >> libdspam.x86_64: W: devel-file-in-non-devel-package /usr/lib64/libdspam.so

> [gnat iridium ~]$ ls -l /usr/lib64/libdspam.*
> -rw-r--r--. 1 root root 175812 2009-11-15 13:54 /usr/lib64/libdspam.a
> -rwxr-xr-x. 1 root root    954 2009-11-15 13:54 /usr/lib64/libdspam.la
> lrwxrwxrwx. 1 root root     17 2009-11-15 13:59 /usr/lib64/libdspam.so 
> -> libdspam.so.7.0.0
> lrwxrwxrwx. 1 root root     17 2009-11-15 13:59 /usr/lib64/libdspam.so.7 
> -> libdspam.so.7.0.0
> -rwxr-xr-x. 1 root root 111000 2009-11-15 13:54 /usr/lib64/libdspam.so.7.0.0
> 
> 
> [gnat iridium ~]$ ldd /usr/bin/dspam_2sql
> 	linux-vdso.so.1 =>  (0x00007fffccfda000)
> ==>	libdspam.so.7 => /usr/lib64/libdspam.so.7 (0x00007f7f4d89e000)

That means you only need the .so.7 and the .so.7.0.0 libs in %{_libdir}.

For the .a lib, follow the Fedora Packaging Guidelines on Static Libraries.
Same for the .la libtool archive. Delete it.

The symlink libdspam.so is not needed at run-time. It's only needed to
make the  -ldspam  linking step work when building software with this lib.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]