[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: abrt and bugzilla



On 11/20/2009 03:28 PM, Neal Becker wrote:
Jiri Moskovcak wrote:

On 11/20/2009 01:15 PM, Jaroslav Reznik wrote:
On Friday 20 November 2009 13:11:49 Jiri Moskovcak wrote:
On 11/20/2009 01:08 PM, Neal Becker wrote:
Jiri Moskovcak wrote:
On 11/20/2009 12:54 PM, Neal Becker wrote:
Jaroslav Reznik wrote:
On Friday 20 November 2009 12:29:34 Neal Becker wrote:
I can't seem to get abrt to work at all.  I suspect it's stuck on
trying to
get bz username password.  I suspect it doesn't work correctly with
kde.


   From what I know it works correctly in KDE, even we have several
   KDE
related

bugreports reported by Abrt.

There are even plans for full KDE support and replacing Dr. Konqui.

Jaroslav

Doesn't work here at all.  When I just tried to send a kernel bug
report, it told me some settings weren't correct, and when I clicked
on bugzilla and filled in username and password, I got:

     abrt-gui
Our job for UUID 725650339 is done.
Traceback (most recent call last):
      File "/usr/share/abrt/CCReporterDialog.py", line 113, in
on_config_plugin_clicked
        plugin.save_settings()
      File "/usr/share/abrt/ABRTPlugin.py", line 100, in save_settings
        self.Settings.save(str(self.Name))
      File "/usr/share/abrt/ABRTPlugin.py", line 51, in save
        self.conf.save(name, self)
      File "/usr/share/abrt/ConfBackend.py", line 68, in save
        True)
gnomekeyring.DeniedError

ABRt dies trying to save/load you stored password if you gnome-keyring
authentication fails, this should be fixed in next update (abrt will
survive the g-k denial, but forget the password when you close it)
which I'm about to do right now.

Jirka

On kde, we shouldn't be using gnomekeyring, I would think.

Yes, I'm planning to write another config backend for kwalet, but didn't
find any usable API reference so far :(

Have you tried that Python keyring library I sent you? It looks like
there's support for both G-K and KWallet with same API. But in any case,
feel free to ask anyone of us (KDE team) for help...


I must have lost it somewhere in my mailbox :-/ Thanks for reminding me,
seems like kwalet and g-k use the same dbus interface, will add support
for this soon.

Thanks,
J

J.

p.s: but according to the error you're seeing you have g-k running, just
the authentication failed.



What's strange too is I tried manually editing
/etc/abrt/plugins/Bugzilla.conf, and filled in Login and Password, and it
still says it's not configured write and prompts me, then hangs forever with
the previous error if I try to fill it in with the gui.


If you change the config file, you need to restart abrt daemon:
$ service abrtd restart

J.
begin:vcard
fn:Jiri Moskovcak
n:Moskovcak;Jiri
email;internet:jmoskovc redhat com
x-mozilla-html:FALSE
version:2.1
end:vcard


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]