[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [PATCH 3/3] dracut has initrd-generic-<version> instead of initrd-<version> (#519185)



On Fri, 2009-09-04 at 17:27 +0200, Tomasz Torcz wrote:
> On Fri, Sep 04, 2009 at 11:14:43AM -0400, Dave Jones wrote:
> > On Fri, Sep 04, 2009 at 10:53:19AM -0400, Jon Masters wrote:
> >  
> >  > The problem I have is that some folks want to include additional drivers
> >  > into their initrd.
> > 
> > examples please.
> 
>   Out-of-tree modules: pvscsi, vmxnet (for VMWare). Generally 
> stuff frowned-upon. BTW, I believe changing Plymouth theme require
> regeneration of initrd.

Yeah. Most of it is "evil" stuff. But I am bringing it up because nobody
else has - the fact of the matter is that there are lots of third party
drivers and tools that are going to break if they cannot regenerate the
initrd. I think it's acceptable for Fedora to completely loathe and
distrust binary drivers, but I really don't think it's acceptable to
actively prevent someone from using them if they would like to.

What'll happen is that lots of people will start building per-kernel
initrd images again, and third party websites will talk about how to
"work around" dracut defaults rather than embracing them because they
won't have an option for a generated, portable image.

Jon.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]