[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mouse pointer freezing in f12 and f11



On Fri, Sep 18, 2009 at 11:01:25AM -0400, Adam Jackson wrote:
 > On Fri, 2009-09-18 at 15:11 +1000, Rodd Clarkson wrote:
 > > On Wed, 2009-09-16 at 21:15 +1000, Rodd Clarkson wrote:
 > > > I'm pretty sure that this problem only occurs before I've cycled through
 > > > a suspend-resume.
 > > > 
 > > > I suspect bluetooth issues because the bluetooth icon appears until I do
 > > > the suspend-resume cycle and then the icon doesn't appear and bluetooth
 > > > doesn't work (but the mouse does).
 > > > 
 > > > Keyboard navigation still works, and I can switch to a VT too.
 > > 
 > > Alright, I've had this happen after a suspend-resume cycle, and it
 > > appears that it's not bluetooth related as the output of xinput is the
 > > same before as after.
 > > 
 > > Do you want me to file a bug on this and then work from there?
 > 
 > Yeah.  Likely a kernel bug.  Try running something like evtest on the
 > pointer device after resume and see if you get events at all:
 > 
 > http://people.freedesktop.org/~ajax/evtest.c
 > 
 > If you get events that way, then X is confused; if you don't, then the
 > kernel driver is confused.

I saw it happen a few days ago too. Same circumstance. Back from resume,
keyboard worked, but no mouse.  Flipping to tty2, and then back to X
made the mouse work again.  Didn't happen again when I tried to repeat it.

	Dave


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]