[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-directory-users] New problem - Mandriva Linux- Administration Server Not Working



Perfect,

Thanks.  It's clear that the admin-server didn't install completely.  The log now shows errors like

...
ClassLoader:  Search <fedora-admserv-1.0.jar> in /home/admin/.fedora-console/jars/
ClassLoader: /home/admin/.fedora-console/jars/ content: <fedora-ds-1.0.jar><fedora-ds-1.0_en.jar><fedora-admserv-1.0.jar>
ClassLoader: fedora-admserv-1.0.jar is already downloaded
ClassLoader: No language file for fedora-admserv-1.0.jar found on local disk, lang=en
ClassLoader: classes.env  NOT in fedora-admserv-1.0.jar
ClassLoader: no manifest found for fedora-admserv-1.0.jar
ClassLoader: No manifest file for fedora-admserv-1.0.jar
ClassLoader: new LocalJarClassLoader fedora-admserv-1.0.jar:{fedora-admserv-1.0.jar }
ClassLoader: Create loader fedora-admserv-1.0.jar
ClassLoader: :loadClass():name:com.netscape.management.admserv.AdminServer
ClassLoader: :loadClass():loading:com.netscape.management.admserv.AdminServer
ClassLoader: com/netscape/management/admserv/AdminServer.class found in fedora-admserv-1.0.jar
ClassLoader: :loadClass():name:com.netscape.management.nmclf.SuiConstants
ClassLoader: :loadClass():loading:com.netscape.management.nmclf.SuiConstants
ClassLoader: com/netscape/management/nmclf/SuiConstants.class  NOT in fedora-admserv-1.0.jar
ClassLoader: :loadClass():name:com.netscape.management.client.topology.AbstractServerObject
ClassLoader: :loadClass():loading:com.netscape.management.client.topology.AbstractServerObject
ClassLoader: com/netscape/management/client/topology/AbstractServerObject.class  NOT in fedora-admserv-1.0.jar
ClassLoader: :loadClass():resolving com.netscape.management.admserv.AdminServer
ClassLoader: :loadClass():name:java.lang.Object
ClassLoader: :loadClass():name:java.lang.Throwable
ClassLoader: :loadClass():name:java.net.MalformedURLException
ClassLoader: :loadClass():name:netscape.ldap.LDAPException
ClassLoader: :loadClass():loading:netscape.ldap.LDAPException
ClassLoader: netscape/ldap/LDAPException.class  NOT in fedora-admserv-1.0.jar
ClassLoader: :loadClass():name:netscape.ldap.LDAPConnection
ClassLoader: :loadClass():loading:netscape.ldap.LDAPConnection
ClassLoader: netscape/ldap/LDAPConnection.class  NOT in fedora-admserv-1.0.jar
ClassLoader: :loadClass():name:com.netscape.management.client.IFrameworkInitializer
ClassLoader: :loadClass():loading:com.netscape.management.client.IFrameworkInitializer
ClassLoader: com/netscape/management/client/IFrameworkInitializer.class  NOT in fedora-admserv-1.0.jar
ClassLoader: :loadClass():name:com.netscape.management.client.IStatusItem
ClassLoader: :loadClass():loading:com.netscape.management.client.IStatusItem
...


I'm going to see if I can figure out where the compile failed, and see if it was something I didn't catch during build.   

Sellers

On Dec 12, 2007, at 5:16 PM, Rich Megginson wrote:

Chris G. Sellers wrote:
> I switched form Solarisx86 to MDK on x86 to do my testing.
>
> I've compiled the source (after having to link some directories to
> match the kernel path) and it appears all is working but the
> Administration Server will not work in the GUI.
>
> I noticed the jar files were not installed for the admin server, so I
> copied those over manually, but now the Admin Console hang when I
> click open the Server group.
>
> At on the console I get
>
> [admin localhost fd]$ ./startconsole
> Uncaught error fetching image:
> java.lang.NullPointerException
>         at java.io.FileInputStream.<init>(FileInputStream.java:103)
>         at java.io.FileInputStream.<init>(FileInputStream.java:66)
>         at
> sun.awt.image.FileImageSource.getDecoder(FileImageSource.java:35)
>         at
> sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:240)
>
>         at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:172)
>         at sun.awt.image.ImageFetcher.run(ImageFetcher.java:136)
>
>
> Nothing in the error logs.  I'm guessing that something didn't get
> installed.
startconsole -D 9 -f console.log
>
> In order to get the build to work, there were a few times that I had
> to symlink :
> n -s
> /var/tmp/dsbuild-fds104/ds/adminserver/work/fedora-adminserver-1.0.3/built/package/Linux2.6.22_x86_glibc_PTH_OPT.OBJ/
> /var/tmp/dsbuild-fds104/ds/adminserver/work/fedora-adminserver-1.0.3/built/package/Linux2.6_x86_glibc_PTH_OPT.OBJ
>
>
>
> because it got the linux kernel version off by a subrevision.   But
> once I did that all was okay.
>
> Any ideas anyone?  I don't want to spend too much time on this because
> my final deployment will probably be on a RHEL or CENTOS server so I'm
> not expecting to have to compile.
>
> Thanks
> Sellers
>
>
>
> ______________________________________________
> Chris G. Sellers            |    NITLE Technology
> 734.661.2318            |    chris sellers nitle org
> AIM: imthewherd            |    GTalk: cgseller gmail com
>
> --
> Fedora-directory-users mailing list
> Fedora-directory-users redhat com
> https://www.redhat.com/mailman/listinfo/fedora-directory-users

--
Fedora-directory-users mailing list
Fedora-directory-users redhat com
https://www.redhat.com/mailman/listinfo/fedora-directory-users

______________________________________________
Chris G. Sellers | NITLE Technology
AIM: imthewherd | GTalk: cgseller gmail com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]