[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-directory-users] Setting up 1.0.4-1 x86_64 on RHES5 64-bit



Hello again,

 

Thanks for the previous help. As advised, I removed the FC5 binary and went with FC6 on Red Hat Enterprise Server 5 x86_64. I’ve now caught up with where I was before. The Directory Server is running OK but I can’t get the admin server to start. The setup/setup script failed with a message:

 

Setting up Administration Server Instance...

ERROR: Administration Server configuration failed.

 

The console starts as advised, but there is no Admin server for it to connect to.

 

I can’t find specific directions for where I’m at now, I guess because this stuff is supposed to “just work”. Striking out on my own, I’ve copied over the templates for start-admin and httpd.conf and edited them. I am using /usr/sbin/http.worker for my web server. After setting sroot and httpd, it seems to start up OK until it looks for modules.

 

Here is the error:

 

[root ansb16 fedora-ds]# ./start-admin

httpd.worker: Syntax error on line 128 of /opt/fedora-ds/admin-serv/config/httpd.conf: Cannot load /opt/fedora-ds/admin-serv/%%%module_dir%%%/modules/mod_access.so into server: /opt/fedora-ds/admin-serv/%%%module_dir%%%/modules/mod_access.so: cannot open shared object file: No such file or directory

 

I’ve looked around. I don’t see the config file location to set %%%module_dir%%%, and what is more, the /opt/fedora-ds/admin-serv/modules directory is empty. I did some finds on the system and cannot find mod_access.so anywhere. So, even if I did set it, where do I point it to?

 

Is there a preferred place to download these modules, or do I need them at all? Or did I skip some part of the setup process?

 

Thanks and Happy Holidays,

Ken.

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]